Decade-old important vulnerability in Jetpack patched on hundreds of thousands of WordPress web sites

Jetpack, a particularly widespread WordPress plugin that gives a wide range of features together with safety features for round 5 million web sites, has acquired a important safety replace following the invention of a bug that has lurked unnoticed since 2012.

Jetpack’s maintainers, Automattic, announced on Tuesday that it had labored intently with the WordPress safety crew to push out an computerized patch for each model of Jetpack since 2.0.

The safety gap is in Jetpack’s API and has been current since model 2.0 was launched over a decade in the past, in 2012.

The vulnerability, which might permit authors on a web site to govern any information in a WordPress set up, was discovered throughout an inside safety audit.

If exploited, the flaw might have allowed a malicious hacker to vary content material on an internet site, which could have compromised the safety of different customers and web site guests.

The excellent news is that Automattic says it has not seen any proof that the vulnerability has been utilized in malicious assaults. Nonetheless, that’s removed from a assure that the safety gap has not been exploited.

If something, now the issue has been made public, there could now be extra decided makes an attempt by cybercriminals to take advantage of the flaw – underlining the significance for all susceptible WordPress-powered web sites to make sure that they’re working a safe model of Jetpack.

Thankfully, WordPress has in place a fairly strong system of routinely pushing out important safety updates in conditions like this, and nearly all at-risk WordPress-powered web sites are more likely to have already been routinely up to date to a safe model of the Jetpack plugin.

Jetpack, identical to WordPress, is open supply. That signifies that anybody can verify the supply code, and it’s ceaselessly claimed that one of many advantages of open supply is that this implies it’s extra doubtless that safety holes shall be discovered.

And but this safety vulnerability went unnoticed for over ten years.

Simply because anybody can verify open supply code for important safety vulnerabilities, it would not essentially imply anybody is.


Editor’s Be aware: The opinions expressed on this visitor creator article are solely these of the contributor, and don’t essentially replicate these of Tripwire.